Symbol(s) not found for architecture i386

REDONDO Julien's Avatar

REDONDO Julien

19 Jul, 2012 10:06 PM

Hello,

I have a problem when i compile my project with your library

The error message is :

Undefined symbols for architecture i386:
"OBJC_CLASS$_Countly", referenced from:

  objc-class-ref in org_nt_taxesejourAppDelegate.o

ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)

and
"OBJC_CLASS$_Countly", referenced from:

  objc-class-ref in org_nt_taxesejourAppDelegate.o

ld: symbol(s) not found for architecture i386

Why ?
How can i do to solve this problem ?

thanks

  1. Support Staff 2 Posted by Atılım on 22 Jul, 2012 07:25 PM

    Atılım's Avatar

    Hi,

    If you add Countly.m and Countly_OpenUDID.m to your project, then there is a possibility that these to .m files is not added at "Build Phases" tab.

    1. Select your project
    2. Select "Build Phases" tab
    3. Select "Compile Sources"
    4. Add Countly.m and Countly_OpenUDID.m under "Compile Sources"

    Hope this helps

  2. 3 Posted by REDONDO Julien on 22 Jul, 2012 09:16 PM

    REDONDO Julien's Avatar

    hi

    Now, i have some others problems : 12

    And what can i do to solve these problems ?

    thanks

  3. Support Staff 4 Posted by Atılım on 24 Jul, 2012 06:54 PM

    Atılım's Avatar

    Hi,

    You should compile Countly.m and Countly_OpenUDID.m as the classic non-ARC retain/release model as described here: https://img.skitch.com/20120411-bcku69k1uw528cwh9frh5px8ya.png

  4. Support Staff 5 Posted by Gorkem on 26 Jul, 2012 07:24 PM

    Gorkem's Avatar

    Have you managed to solve your issues? Let us know if the problem persists :)

  5. 6 Posted by Redondo julien on 27 Jul, 2012 06:07 AM

    Redondo julien's Avatar

    No this problem is not resolved
    I have always the same error

    What can i do for solve this problem???

    Tank for your response

  6. Support Staff 7 Posted by Gorkem on 27 Jul, 2012 06:10 AM

    Gorkem's Avatar

    Did you try what Atilim has written in his previous post?

  7. 8 Posted by REDONDO Julien on 27 Jul, 2012 07:22 AM

    REDONDO Julien's Avatar

    Yes, i tried.
    But this solution doesn't work.
    I have always the same error, 12 errors like before.

    Thanks a lot

  8. Support Staff 9 Posted by Gorkem on 03 Aug, 2012 08:50 AM

    Gorkem's Avatar

    Could you please try searching on the web with the words or phrases you see on the user interface? We couldn't replicate this issue, and suspect that it's a configuration problem.

    Thanks.

  9. 10 Posted by REDONDO Julien on 03 Aug, 2012 09:17 AM

    REDONDO Julien's Avatar

    Hello,

    Yes my problem is ok now.

    In the capture here, https://img.skitch.com/20120411-bcku69k1uw528cwh9frh5px8ya.png, yhe compiler flag is -fnoobjc-arg

    Or, it's wrong.

    In this case, the good compiler flag is -fno-objc-arc

    Now it's good and the application compiles.

    Thank for your help

  10. Onur closed this discussion on 04 Aug, 2012 05:24 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Jul, 2014 04:31 PM
23 Jul, 2014 03:28 PM
22 Jul, 2014 08:06 AM
21 Jul, 2014 10:03 AM
17 Jul, 2014 04:38 PM

 

11 Jul, 2014 09:07 AM
07 Jul, 2014 07:53 AM
03 Jul, 2014 08:21 PM
01 Jul, 2014 11:07 PM
01 Jul, 2014 07:18 AM
30 Jun, 2014 06:34 PM