System requirements

Follow

Operating system

  • Ubuntu 16.04, 18.04, 18.10 (excluding Ubuntu 19.4)
  • Red Hat Enterprise Linux 6.9 or higher (excluding RHEL 8.0)
  • CentOS Linux 6.9 or higher

Countly doesn't work on Microsoft Windows or MacOS platforms.

Software

  • NodeJS 8.x
  • MongoDB 3.6.x

64-bit support only

32-bit MongoDB processes are limited to about 2 GB of data. The reason for this is that the MongoDB storage engine uses memory-mapped files for performance. For this reason, MongoDB decided not to support 32 bit, so we also dropped 32-bit support for new installations, starting from version 16.02.

CPU

Countly requires at least 2 CPUs (the more the better) for a good user experience.

RAM

  • At least 2 GB of RAM for testing purposes (4 GB of RAM for Enterprise Edition)
  • 4 GB of RAM for moderate traffic
  • 16-64 GB RAM or more for high traffic servers

Note that you may need different installation methods, such as sharding, to distribute traffic to several servers for multi-billion API requests per month. Contact the Countly team to discuss how to deploy Countly in a sharded environment.

Countly will not work on Linux servers with less than 2 GB of RAM.

Disk

Requirements for disk depends on the number of events and segmentations you send to your server.

  • At least 20GB of disk space for testing purposes or low-traffic servers
  • At least 100 GB of disk space for moderate traffic
  • 1 TB or more for high traffic servers (SSD recommended)

For a more detailed breakdown of the system requirements, please contact us directly to get hardware recommendations for your specific usage scenario.

Was this article helpful?
0 out of 0 found this helpful

Looking for help?