Unable to change the API URL for dashboard

Hi,
I'm using AWS RHEL. Countly Enterprise Edition. I want to change the API URL for dashboard to a static one and skip using nginx for forwarding requests to API and dashboard based on the request type using proxies. Could you guide me on how to do this?

Thanks in advance.

0

Comments

4 comments
  • Hello,
    if I understood you correctly, then in theory changing this setting should be enough:

    your server should have countly.config.js at the same place, change it there to hostname + port or whatever you want to use as your API url.

    0
    Comment actions Permalink
  • Thanks for the quick reply. I changed this and restarted Countly by using "countly restart". But it is still trying to hit the dashboard URL instead of the URL mentioned in countlyCommon.API_URL.
    By dashboard URL, I mean countlyGlobal.path which is domain used to access dashboard.

    0
    Comment actions Permalink
  • For UI/Browser changes to kick in, you need either disable production mode (Top cog -> Configurations -> Frotnend -> Production mode -> Disable -> Apply)

    Or regenerate production files by running countly task dist-all

    Afterward clear browser cache by Ctrl + F5

    0
    Comment actions Permalink
  • Thanks a bunch. This helped a lot. I was missing the regeneration of production files.

    0
    Comment actions Permalink

Please sign in to leave a comment.