Internet Explorer (IE) reporting incorrect version number

I'm tracking one of our intranet web applications, and under browsers, it shows IE7 as the dominant browser with Chrome and Edge as 2nd and 3rd.

IE11 is probably the majority of use and the site I'm tracking does use the x-ua-compatible content="IE=edge" tag in the header. When I hit the site with IE11, and bring up the developer tools, it shows being in IE11 mode.

Why is IE being reported as version 7? I really don't think we have any IE11 browsers in the company.

0

Comments

6 comments
  • x2rider:

    I really don't think we have any IE11 browsers in the company

    I meant to say I really don't think we have any IE7 browsers in the company

    0
    Comment actions Permalink
  • According to whatismybrowser.com it reports IE11 user agent as this:

    Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko

    Which they translate to: Internet Explorer 11 on Windows 10

    Is Countly incorrectly picking up the 7.0 above instead of the 11.0?

    0
    Comment actions Permalink
  • Hello,
    we are using this library for determining browsers:

    currently on my dev server inside countly/plugins/web/node_modules/useragent/package.json the version shows
    "version": "2.2.1"

    and it correctly identifies my IE11 as IE 11.

    Maybe you have older version, then running
    countly plugin upgrade web

    could help

    0
    Comment actions Permalink
  • Mine says version 2.1.13
    I ran the countly plugin upgrade web, and it applied indexes to all of my apps, but in the end, the package.json version was still 2.1.13

    0
    Comment actions Permalink
  • Ok, I will investigate that, for now, can you cd to countly/plugins/web
    and run
    npm update

    0
    Comment actions Permalink
  • That did the trick! It's now version 2.3.0
    I just hit the site with IE11 and now it shows an entry for IE11

    0
    Comment actions Permalink

Please sign in to leave a comment.