Countly server failed to start

I am trying to run the latest countly server cloned from github. Unfortunately, it failed. Could you help take a look?

Following is the error logs,

Error: error:0606506D:digital envelope routines:EVP_DecryptFinal_ex:wrong final block length
at Error (native)
at Decipher.Cipher.final (crypto.js:153:26)
at Object.exports.decrypt (/usr/countly-server/api/utils/utils.js:66:27)
at pluginManager.dbConnection (/usr/countly-server/plugins/pluginManager.js:583:60)
at pluginManager.singleDefaultConnection (/usr/countly-server/plugins/pluginManager.js:534:21)
at new Manager (/usr/countly-server/api/parts/jobs/manager.js:30:21)
at Object. (/usr/countly-server/api/parts/jobs/manager.js:400:21)
at Module._compile (module.js:413:34)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Module.require (module.js:367:17)
at require (internal/module.js:20:19)
at Object. (/usr/countly-server/api/parts/jobs/index.js:4:19)
at Module._compile (module.js:413:34)
at Object.Module._extensions..js (module.js:422:10)
2016-12-27T07:37:31.701Z: INFO [jobs:manager] Starting job manager
crypto.js:153
var ret = this._handle.final();

Thanks,
Felix

0

Comments

2 comments
  • Hi Felix,

    Can you answer following?

    1. What is the Linux distribution you used? RAM / CPU?
    2. What are the steps you did?
    3. Which method did you use to install?

    Please give as much information as possible.

    0
    Comment actions Permalink
  • Also please use releases instead of github code as it might be in broken state when in transition

    0
    Comment actions Permalink

Please sign in to leave a comment.