Android SDK - events populating MongoDB, but not appearing in Dashboard.

I'm currently testing Countly before fully integrating it with one of my company's mobile applications. Although the tool itself works quiet nice, there are some issues regarding events, or rather their abscence in Dashboard. Android Department representative states that the app itself is reporting success during both generation and dispatch stages. Unfortunately it seem like these events aren't properly registered by Countly's API/Dashboard, leading to "This application doesn't have any custom events" in Events Overview. I'll be happy to provide further information, just let me know what would be most useful for this specific case. Cheers.

EDIT.
I can see these events coming up in Request Logs and apparently they are also properly added in mongodb, however dashboard fails to parse this data in Events view, most likely due to missing api_key in get_events method's call.

bunch of events saved in mongo

0

Comments

3 comments
  • Official comment

    Hello,
    The image from the event you showed is from a view. It would not be shown in the "events" section.

    I would like you to share a couple of thigs:
    * SDK init block
    * call of how you are recording the event
    * SDK logs from logcat. But before that you would need to enable logging in the SDK. After that I would want you to send the logs from the moment the SDK is initialised to 1 minute after recording the event.

    Comment actions Permalink
  • Ok, it turns out enabling "Batch writes on single process" fixes the problem somehow.

    0
    Comment actions Permalink
  • Arturs Kadikis unfortunately I do not possess this kind of information, however I noticed that in general the data stored in mongo is very slowly processed by API/Dashboard. Events collected by mongo started to appear only after disabling aformentioned setting and even then they have been fully mapped after almost three days despite all the necessary data already existing within local environment. I realize there is batch write frequency setting (set to default 10), but it doesn't explain why it processes such a small data sample with only a couple of test values at a snail's pace. Nonetheless the initial problem has been resolved, so it's just a matter of further tweaking of settings and optimization.

    0
    Comment actions Permalink

Please sign in to leave a comment.