Can not access to the User management page v22.0.3

v22.0.3 can not open the User management page is there a way to fix?

1

Comments

8 comments
  • 0
    Comment actions Permalink
  • Hi,

    Is there any error on the browser console?

    Did you try cleaning the browser cache?

    Could you please try to open it in another browser or incognito mode and inform us the outcome?

    0
    Comment actions Permalink
  • Hi Kevin,

    I tried with 3 different browsers these are the errors

     

     

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Brave Browser V1.37.116,  incognito mode.

     

    0
    Comment actions Permalink
  • Hi Team,

    Could you please inform us how did you perform the upgrade to v22.0.3? (step-by-step)

    Also, could you please confirm if you're using Enterprise or Comunity Edition?

    0
    Comment actions Permalink
  • There was a single step, and that's updating the version in docker-compose file, twice;

     

    20.11.2 -> 21.11.0 -> v22.03

     

    Here's the compose file itself:

     

    ```

    version: "3.7"

    services:
      countly-api:
        image: 'countly/api:v22.03'
        container_name: xplore_countly_api
        environment:
          - COUNTLY_PLUGINS=mobile,web,desktop,plugins,density,locale,browser,sources,views,enterpriseinfo,logger,systemlogs,populator,reports,crashes,push,star-rating,slipping-away-users,compare,server-stats,dbviewer,assistant,times-of-day,compliance-hub,video-intelligence-monetization,alerts,onboarding,consolidate
          - COUNTLY_CONFIG__MONGODB_HOST=mongo
        restart: always
        external_links:
          - xplore_mongo:mongo
        ports:
          - 127.0.0.1:3007:3001
            
      countly-frontend:
        image: 'countly/frontend:v22.03'
        container_name: xplore_countly_frontend
        environment:
          - COUNTLY_PLUGINS=mobile,web,desktop,plugins,density,locale,browser,sources,views,enterpriseinfo,logger,systemlogs,populator,reports,crashes,push,star-rating,slipping-away-users,compare,server-stats,dbviewer,assistant,times-of-day,compliance-hub,video-intelligence-monetization,alerts,onboarding,consolidate
          - COUNTLY_CONFIG__MONGODB_HOST=mongo
          - COUNTLY_CONFIG_HOSTNAME=localhost

        external_links:
          - xplore_mongo:mongo
        ports:
          - 127.0.0.1:6001:6001
        restart: always
        deploy:
          # There is usually no need in multiple frontends, so throttling down resources for it
          mode: global
          resources:
            limits:
              cpus: '0.5'

    ```

     

    Countly shares MongoDB with another app through Docker networking.

     

    Here's the nginx config too:

     

    ```

    upstream api {
        server 127.0.0.1:3007;
    }

    upstream frontend {
        server 127.0.0.1:6001;
    }

    server {
        server_name  countly.xplorelabs.com;

        access_log  off;

        location = /i {
                proxy_pass http://api;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_set_header X-Real-IP $remote_addr;
        }

        location ^~ /i/ {
                proxy_pass http://api;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_set_header X-Real-IP $remote_addr;
        }

        location = /o {
                proxy_pass http://api;
        }

        location ^~ /o/ {
                proxy_pass http://api;
        }

        location / {
                proxy_pass http://frontend;
                proxy_set_header Host $http_host;
        }


        listen [::]:443 ssl; # managed by Certbot
        listen 443 ssl; # managed by Certbot
        ssl_certificate /etc/letsencrypt/live/countly.xplorelabs.com/fullchain.pem; # managed by Certbot
        ssl_certificate_key /etc/letsencrypt/live/countly.xplorelabs.com/privkey.pem; # managed by Certbot
        include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
        ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

    }

     

    server {
        if ($host = countly.xplorelabs.com) {
            return 301 https://$host$request_uri;
        } # managed by Certbot


        listen   80;
        listen [::]:80;
        server_name  countly.xplorelabs.com;
        return 404; # managed by Certbot


    }

    ```

     

    We're using the CE.

    0
    Comment actions Permalink
  • Hi,

    Thank you for your inputs.

    We have corrected that and to solve it, we kindly ask you to switch your image to the latest minor version.

    Regards,

    0
    Comment actions Permalink

Please sign in to leave a comment.