Can't access Applications page

When i click in the option Applications on menu, it keeps redirecting me to the Overview page.

This is happening in different browsers, in different computers, even after cleaning browser data/cache, in different Countly accounts...

-1

Comments

8 comments
  • Official comment

    Hello Ricardo,

    Thanks for reaching out to us. This most probably must be happening for admins and users but should be okay for global admins, this is a known bug and a fix for this can be found in master. So you can use the fix available in master or it'll be fixed in a patch release. Let me know if you need further assistance. Thank you :)

    Comment actions Permalink
  • Hello Subodh,

    I have similar error. Installed both Centos7 & Ubuntu 20.04 gives the same reaction. I'm Global Admin in DB, Countly version is also 20.04. 

    It seems frontend wants to go

    http://127.0.0.1:6001/i/apps/create?args= 

    which is not a server side. I think port should be 3001.

    Any ideas ?

    Ricardo did you solve your problem?

    0
    Comment actions Permalink
  • Hello Ibrahim,

    Yes, it should go to 3001; however you should never access by a specific port. Simply accessing http://127.0.0.1/i/apps/create is fine, as nginx will redirect it to correct process. Let me know if you need further assistance.

    0
    Comment actions Permalink
  • Hello again,

    I did not access directly to ports. Maybe, I misunderstood.

    When I want to create an app, there is no redirection. And I see some page errors like the following:

     

    Also management menu items are not running. The hint shows a link that has 6002 port. That's why I thought wrong.

    It is not running at the moment.

    0
    Comment actions Permalink
  • Hello Ibrahim,

    Then you need to use dashboard as
    127.0.0.1/dashboard
    and not 127.0.0.1:6001/dashboard

    or if for some reason you need to access dashboard specifically by 6001, you'll need to configure dashboard to use API with 3001 through this config file, setting it to 127.0.0.1:3001

    0
    Comment actions Permalink
  • Oh, I got the point. But :( 

    When I want to access http://127.0.0.1/dashboard, nginx gives me 502 Bad Gateway error. There is no reason to change ports in my side. I have only changed 6001 port to 6002 because some other process is using 6001. 

     

    0
    Comment actions Permalink
  • Then, you will have to update nginx configuration to use 6002 port instead of 6001.

    0
    Comment actions Permalink
  • Done!

    Thank you. 

    0
    Comment actions Permalink

Please sign in to leave a comment.