Adding Countly to my docker swarm not working

I wanted to add Countly to my docker swarm setup. I am currently using docker swarm with traefik as a reverse proxy. I am using the docker-compose file for swarm from the docs and modified it a bit. The services are starting and running. However I cannot connect to the countly instance, the gateway times out. I attached all logs and config files I am using below via pastebin. I am not sure why this happens and have not found anything yet.

I could connect to the database via Mongod Compass.

Btw. I am already using traefik as a reverse proxy, so I would not need nginx. Because, I first wanted to get the provided file working.

 

Links to pastebins:

docker-compose.yml

countly api logs

countly frontend logs

nginx.server.conf

mongodb logs

0

Comments

4 comments
  • Official comment

    Hi,

    From api/frontend logs you can see that they cannot authenticate against MongoDB. The problem is that MongoDB authentication requires some sidecar to set it up prior to starting other containers, we don't have it there yet. I'd suggest either removing authentication, or setting up database & required authentication prior to starting Countly containers.

    Comment actions Permalink
  • Hi,

    ok thanks for the quick reply. I will take a look at this.

    But what is weird is that I just opened a port for nginx to bypass traefik and I get redirected to the setup page. So there is also so problems with my traefik setup but I am not sure what. When routing via traefik it times out and when directly talking to nginx I get to the setup page.

    0
    Comment actions Permalink
  • Sorry :D

    I forgot to restart traefik after adding the new network to my traefik yml file. It works now.

    0
    Comment actions Permalink
  • NP 

    0
    Comment actions Permalink

Please sign in to leave a comment.