Countly frontend jQuery version 3.4 has a vulnerability per CVE (CVE-2020-11022)

In jQuery versions greater than or equal to 1.2 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11022

Any chance of this being resolved anytime soon?

0

Comments

1 comment
  • It's actually looking at this file:  /javascripts/dom/jquery/jquery.js which says:

     

     jQuery JavaScript Library v3.4.1
    0
    Comment actions Permalink

Please sign in to leave a comment.