java sdk problem

Hi,

I try to integrate java sdk to my java ee project. On documentation it says:

Config config = new Config("http://YOUR.SERVER.COM", "YOUR_APP_KEY") .enableTestMode() .setLoggingLevel(Config.LoggingLevel.DEBUG) .enableFeatures(Config.Feature.Events, Config.Feature.Sessions, Config.Feature.CrashReporting, Config.Feature.UserProfiles) .setDeviceIdStrategy(Config.DeviceIdStrategy.UUID); File targetFolder = new File("d:\\__COUNTLY\\java_test\\"); Countly.init(targetFolder, config);

 

But on java sdk jar there is not Config and Countly classes. Is there any problem about that sdk ?

Can you help me ?

0

Comments

6 comments
  • Hello, the SDK has both of those things. I would assume that some errors has happened while you added that jar into your project or while importing those SDK related things.

    0
    Comment actions Permalink
  • Did you add the maven dependancy? 

    0
    Comment actions Permalink
  • İ added maven dependency and repository too. As i declared above that in jar there are no Config and Countly classes. Documentation above is wrong.

    0
    Comment actions Permalink
  • I can assure you that it is not wrong. Those 2 classes are core to the SDK and it would not function without them.

    0
    Comment actions Permalink
  •  

    As you see above, jar files don't include Countly and Config classes. So documentation above code can not be implemented.

    0
    Comment actions Permalink
  • Finally I solved. As you mentioned above, installation both core and java sdk jars was problem.

    On my pom.xml:

    <dependency>
    <groupId>ly.count.sdk</groupId>
    <artifactId>java</artifactId>
    <version>19.09-sdk2-rc</version>
    </dependency>

    <dependency>
    <groupId>ly.count.sdk</groupId>
    <artifactId>core</artifactId>
    <version>19.09-sdk2-rc</version>
    </dependency>

     

    0
    Comment actions Permalink

Please sign in to leave a comment.